Author Topic: 520BA Engine/Scimitar Prop  (Read 1063 times)

James Fordyce

  • ABS Member
  • Full Member
  • Posts: 5
520BA Engine/Scimitar Prop
« on: October 12, 2011, 09:49:04 AM »
This year I installed a new Scimitar on my V35B with a 520-BA--leaking persisted from all 3 blade hubs, and, after evaluation and attempted fix by Hartzell, was sent another new Scimitar, which is again throwing what appears to be oil over my windscreen, even after about 11 hours---I have friends who have the same issue with a new Scimitar on the same model engine---question--has anyone else had a similar problem????--front engine seals were replaced, inspected, and are not leaking, the back end of the blades definitely show grease or oil being slung up the blade from the hubs of all 3 blades--a Commander on our field with a different engine and scimitar has had zero problems---anyone with a similar problem??  Hartzell has been helpful evaluating the problem, but frankly I am tired looking at my airplane without a propeller--Jim Fordyce

Tom Pelz

  • ABS Member
  • Full Member
  • Posts: 436
520BA Engine/Scimitar Prop
« Reply #1 on: October 12, 2011, 02:36:29 PM »
James,

Take the spinner off.  Are there any covers on the grease zerts?

I have a Hartzell prop.  It did the same thing for a while.  Then I put the Lumax LX-1458 Silver Rubber Grease Fitting Cap, on each fitting.   I use a bit of safety wire to keep the caps on the Zert.   My windshield no longer gets dirty.

If it gets oily, then you have a problem with the front crank seal.  That is a different problem.

TomTom Pelz2011-10-12 22:37:05

Jim Hillabrand

  • ABS Member
  • Full Member
  • Posts: 21
520BA Engine/Scimitar Prop
« Reply #2 on: October 13, 2011, 08:31:13 AM »
Not much help James but I've had the Scimitar on a 520BB for 600+ hours with zero issues.

Good luck.



Jim

Mike Edwards

  • ABS Member
  • Full Member
  • Posts: 9
520BA Engine/Scimitar Prop
« Reply #3 on: October 13, 2011, 08:57:22 AM »
Years ago I had a similar problem after a new prop install.  Turned out it had nothing to do with the prop itself, but the installer had rolled an o-ring when installing it.  Just a poor (or unlucky) installation.  Removing and reinstalling it by a proper shop cured the problem.

Mike E

Brian Conley

  • ABS Member
  • Full Member
  • Posts: 264
520BA Engine/Scimitar Prop
« Reply #4 on: October 13, 2011, 04:30:16 PM »
Tom,

Where do you get the grease zerk covers? Will they work on the zerks on our landing gear? The ones I bought from Performance Aero crack and fall get loose a few months...Brian Conley2011-10-14 00:31:15

Scott Newpower

  • ABS Member
  • Full Member
  • Posts: 223
520BA Engine/Scimitar Prop
« Reply #5 on: October 15, 2011, 12:15:26 PM »
I bought a bag from them a few years ago expecting to go thru them at a pretty good clip.  But I'm not. Maybe one every couple of years.

Tom Pelz

  • ABS Member
  • Full Member
  • Posts: 436
520BA Engine/Scimitar Prop
« Reply #6 on: October 15, 2011, 04:12:22 PM »
Brian,

I bought about 200 of them from the manufacturer a few years ago.

These are the fat red ones.  I put them on my landing gear and my prop.

When I find out where / who I bought them from, I will let your know.

Tom

Brian Conley

  • ABS Member
  • Full Member
  • Posts: 264
520BA Engine/Scimitar Prop
« Reply #7 on: October 17, 2011, 03:20:51 PM »
Thanks!

Tom Pelz

  • ABS Member
  • Full Member
  • Posts: 436
520BA Engine/Scimitar Prop
« Reply #8 on: October 18, 2011, 02:53:14 PM »
Brian,

There is an outfit named Jenkins.

Lubricaps (Box of 100 pcs.)

PART #: M-24259

LIST PRICE: 30.00

Lubricaps (Box of 100 pcs.)

Their telephone number is:

800-438-3003

      or

704-392-7371